(Advertising options)
Results 1 to 9 of 9
  1. #1
    Sean79's Avatar
    Sean79 is offline New to BMW.SG!
    Overall activity: 0%
    Achievements:
    1 year registered1000 Experience Points
    Join Date
    Jul 2011
    Posts
    27
    Points
    2,170
    Level
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Loud "Wong" sounds on cold starts on 525i

    Dear All,

    I recently bot a used 06 525i and recently the ride produces a very loud "Wong" sound when the engine is idling from a cold-start.

    Have taken it to my workshop and they can't detect any electrical or mechanical faults.
    The sound goes away after about 4 mins of driving or idling.

    Anyone experienced the same issues?

    Would appreciate any kind advice.

  2. #2
    iScoupe's Avatar
    iScoupe is offline UNSTOPPABLE!
    Overall activity: 0%
    Achievements:
    Recommendation Second ClassVeteran25000 Experience Points
    Join Date
    May 2005
    Location
    Singapore
    Posts
    12,409
    Points
    30,269
    Level
    1
    Thanks
    76
    Thanked 238 Times in 208 Posts

    Re: Loud "Wong" sounds on cold starts on 525i

    Haha not long ago there is a same thread with "Wong wong Wong...." u might want search.

    Think totoseow has the YouTube to show u.

  3. #3
    rodders's Avatar
    rodders is offline 9000 RPM
    Overall activity: 5.0%
    Achievements:
    Veteran10000 Experience Points
    Join Date
    Jun 2004
    Location
    Abbey Road Studio
    Posts
    6,047
    Points
    20,426
    Level
    1
    Thanks
    70
    Thanked 69 Times in 54 Posts

    Re: Loud "Wong" sounds on cold starts on 525i

    Quote Originally Posted by iScoupe View Post
    Haha not long ago there is a same thread with "Wong wong Wong...." u might want search.

    Think totoseow has the YouTube to show u.
    That one happens when the car is moving lah and not at cold starts. Nevertheless, it's still from the same Wong clan.

  4. #4
    iScoupe's Avatar
    iScoupe is offline UNSTOPPABLE!
    Overall activity: 0%
    Achievements:
    Recommendation Second ClassVeteran25000 Experience Points
    Join Date
    May 2005
    Location
    Singapore
    Posts
    12,409
    Points
    30,269
    Level
    1
    Thanks
    76
    Thanked 238 Times in 208 Posts

    Re: Loud "Wong" sounds on cold starts on 525i

    Quote Originally Posted by rodders View Post
    That one happens when the car is moving lah and not at cold starts. Nevertheless, it's still from the same Wong clan.
    Ur super stock E60 have Wong Wong ??

  5. #5
    rodders's Avatar
    rodders is offline 9000 RPM
    Overall activity: 5.0%
    Achievements:
    Veteran10000 Experience Points
    Join Date
    Jun 2004
    Location
    Abbey Road Studio
    Posts
    6,047
    Points
    20,426
    Level
    1
    Thanks
    70
    Thanked 69 Times in 54 Posts

    Re: Loud "Wong" sounds on cold starts on 525i

    Quote Originally Posted by iScoupe View Post
    Ur super stock E60 have Wong Wong ??
    Have wor...from one uneven wear tyre........

  6. #6
    MW's Avatar
    MW
    MW is offline UNSTOPPABLE!
    Overall activity: 46.0%
    Achievements:
    Recommendation Second ClassSocialOverdriveVeteran50000 Experience Points
    Join Date
    May 2004
    Location
    Girls Love my sexy eyes
    Posts
    11,633
    Points
    133,589
    Level
    1
    Thanks
    490
    Thanked 2,122 Times in 1,378 Posts

    Re: Loud "Wong" sounds on cold starts on 525i

    Toto says confirm its a Bee

  7. #7
    davidtch's Avatar
    davidtch is offline Blistering Quick
    Overall activity: 6.0%
    Achievements:
    Veteran10000 Experience PointsSocial
    Join Date
    Aug 2005
    Location
    Somewhere along Kallang River
    Posts
    3,593
    Points
    24,428
    Level
    1
    Thanks
    669
    Thanked 251 Times in 223 Posts

    Re: Loud "Wong" sounds on cold starts on 525i

    Quote Originally Posted by MW View Post
    Toto says confirm its a Bee
    Ur Yam 5 also from Wong clan??

  8. #8
    MW's Avatar
    MW
    MW is offline UNSTOPPABLE!
    Overall activity: 46.0%
    Achievements:
    Recommendation Second ClassSocialOverdriveVeteran50000 Experience Points
    Join Date
    May 2004
    Location
    Girls Love my sexy eyes
    Posts
    11,633
    Points
    133,589
    Level
    1
    Thanks
    490
    Thanked 2,122 Times in 1,378 Posts

    Re: Loud "Wong" sounds on cold starts on 525i

    so far no leh. My Yam 5 stil very quiet. Seems to be a problem for the pre-FL E60. I only hear "Ooooo" in my LCi E60 but tats probably cos I was touching myself

  9. #9
    Lorinser's Avatar
    Lorinser is offline Rolling Start...
    Overall activity: 1.0%
    Achievements:
    Veteran5000 Experience Points
    Join Date
    May 2006
    Posts
    104
    Points
    6,847
    Level
    1
    Thanks
    0
    Thanked 2 Times in 2 Posts

    Re: Loud "Wong" sounds on cold starts on 525i

    it will be hard to see exactly what is wrong, especially it will go away very soon.
    hope it is nothing serious.
    good luck

Members who have read this thread: 0

There are no members to list at the moment.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •